使用rpm安装指定版本docker(1.12.6)的详细步骤

一.原因

  如果系统是centos7.3,直接使用yum install docker安装的docker版本是1.13.1,导致在创建容器的会报错,错误如下:

所以为了防止安装高版本的docker引发的错误,需要安装1.12.6版本的docker.

二.安装步骤

1.下载docker安装包

下载地址: https://yum.dockerproject.org/repo/main/centos/7/packages/

需要下载2个文件,都是1.12.6版本,如下:

2.将下载好的rpm包上传到服务器

3.安装rpm包

注: 按照顺序安装,先安装docker-engine-selinux-1.12.6-1.el7.centos.noarch.rpm,

再安装docker-engine-1.12.6-1.el7.centos.x86_64.rpm

命令:

rpm -ivh docker-engine-selinux-1.12.6-1.el7.centos.noarch.rpm
rpm -ivh docker-engine-1.12.6-1.el7.centos.x86_64.rpm

4.安装完成后,查看docker版本

命令:

docker -v

docker version

到此这篇关于使用rpm安装指定版本的docker(1.12.6)的文章就介绍到这了,更多相关rpm安装docker内容请搜索www.887551.com以前的文章或继续浏览下面的相关文章希望大家以后多多支持www.887551.com!

THE END
喜欢就支持一下吧
点赞10 分享